uffffffffff

per si no us en havíeu adonat el bloc havia estat inaccessible des de feia com a mínim 24h

i d’aquestes 24h me n’h estat com a mínim 14 per trobar-hi l’entrellat, ja que la sol·lució ni molt menys era òbvia…

els fets:

després de remenar molt el bloc ahir tot funcionava perfectament

tot mirant els logs de l’apache (a saber perquè em va picar mirar-los) vaig veure que un vhost que havia creat feia molt temps donava problemes, així que vaig esborrar el fitxer de la configuració del vhost i vaig reiniciar l’apache, que com que em va donar problemes i no es va iniciar del tot correctament vaig decidir reiniciar el servidor

a partir de reiniciar ja no funcionava el bloc! però el més estrany de tot, el phpmyadmin que tinc instal·lat tampoc funcionava i li faltaven MOLTS fitxers (no era el cas del wordpress), després de barallar-me molt amb el bloc, vaig copiar de nou els fitxers del phpmyadmin i aquest ja funcionava bé, però el bloc quan entraves a la seva pàgina principal no mostrava res, ni títol, ni missatges d’error, res de res, el codi font era zero, entrant-hi amb el links2 (navegador web per terminal) donava un error de socket

per acabar d’embolicar que fa fort si entrava a la secció d’administració del bloc SÍ que funcionava aquest, però tornant a la pàgina inicial o qualsevol visualització de les entrades escrites tornava una pàgina amb blanc

més problemes, si baixava al portàtil el .zip del wordpress des del navegador web o ho feia amb el wget des del servidor donaven un md5sum diferent! cada vegada que entrava a la portada a al log d’errors de l’apache sortia

[Fri Mar 16 17:52:48 2007] [notice] child pid 6278 exit signal Segmentation fault (11)

havia provat de tot, canviar la base de dades del wordpress, canviar-li el path diverses vegades, fer una instal·lació completament nova del wordpress, recompilar l’apache i el php (el mysql no podia ser perquè no em donava cap problema) i res

buscant al google informació sobre pàgines en blanc del wordpress o als fòrums de gentoo sobre el wordpress tampoc donaven cap resultat

buscar l’error de l’apache m’enviava a una pàgina de la documentació de l’apache que em deia que recompilés l’apache amb no se quines opcions i fes una depuració complicadíssima

al bugzilla del gentoo tan per l’apache com pel php no hi havia res que s’assemblés al meu problema i tan el php com l’apache són estables en la versió que els tinc, però un informe d’error referint-se al mediawiki que no funcionava bé l’última versió estable del php però que l’anterior (el canvi de php5.2 a php5.1) ho arreglava, així que he recompilat una versió menys nova del php i …

voilà, de moment funciona!!

Deixa un comentari

L'adreça electrònica no es publicarà. Els camps necessaris estan marcats amb *